Workflow loading issue

Incident Report for Locomote

Postmortem

We apologise for any disruption this caused by our recent partial outage, which affected workflow and report loading.

The root cause of the issue was preparatory work recently put in place for planned future upgrades, which revealed a configuration mismatch between our production and development/test environments that allowed this issue to bypass both manual and automated testing.

We’ve since adjusted our test environments to align with the production configuration in question, and confirmed the issue is now correctly caught in automated tests. We are confident this class of problem is now remediated.

Posted Mar 21, 2025 - 09:44 AEDT

Resolved

Reporting auth issue is now also resolved, we are monitoring for any further issues.
Posted Mar 19, 2025 - 10:31 AEDT

Monitoring

Reporting auth issue is now also resolved, we are monitoring for any further issues.
Posted Mar 19, 2025 - 10:31 AEDT

Update

Workflow loading issue has been resolved. We're investigating a secondary issue with reporting access for admins.
Posted Mar 19, 2025 - 09:14 AEDT

Identified

The issue has been identified and a fix is being worked on.
Posted Mar 19, 2025 - 08:59 AEDT
This incident affected: Travel Management Platform.